Degradation of Service

Incident Report for SchoolMint

Resolved

This incident has been resolved.
Posted Nov 14, 2019 - 11:45 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 14, 2019 - 11:43 PST

Investigating

Hero is currently experiencing a degradation of service. Our team is actively working to resolve the issue.
Posted Nov 14, 2019 - 07:00 PST
This incident affected: SchoolMint Hero.