SchoolMint Hero Slowness

Incident Report for SchoolMint

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 09:36 PDT

Update

The SchoolMint Hero slowness issue has been resolved.
Posted Oct 28, 2025 - 09:35 PDT

Investigating

We are currently investigating reports of slowness affecting SchoolMint Hero. Our team is working to identify the cause and will update this page when we have an update.
Posted Oct 27, 2025 - 10:00 PDT
This incident affected: SchoolMint Hero.